fog-core.gemspec 1.37 KB
Newer Older
1
2
3
4
5
6
7
8
9
10
11
12
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'fog/version'

Gem::Specification.new do |spec|
  spec.name          = "fog-core"
  spec.version       = Fog::VERSION
  spec.authors       = ["Evan Light", "Wesley Beary"]
  spec.email         = ["evan@tripledogdare.net", "geemus@gmail.com"]
  spec.summary       = %q{Shared classes and tests for fog providers and services.}
  spec.description   = %q{Shared classes and tests for fog providers and services.}
13
  spec.homepage      = "https://github.com/fog/fog-core"
14
15
  spec.license       = "MIT"

16
  spec.files         = `git ls-files`.split($/)
17
18
19
20
21
  spec.executables   = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
  spec.test_files    = spec.files.grep(%r{^(test|spec|features)/})
  spec.require_paths = ["lib"]

  spec.add_dependency('builder')
22
23
  spec.add_dependency('excon', '~>0.33')
  spec.add_dependency('formatador', '~>0.2')
24
25
26
27
28
29
30
  spec.add_dependency('mime-types')
  spec.add_dependency('net-scp', '~>1.1')
  spec.add_dependency('net-ssh', '>=2.1.3')

  spec.add_development_dependency('rake')
  spec.add_development_dependency('yard')
  spec.add_development_dependency('thor')
31
32
  spec.add_development_dependency('minitest')
  spec.add_development_dependency('minitest-stub-const')
33
34
35
  spec.add_development_dependency('pry')
  spec.add_development_dependency('coveralls')
end