Commit 85ca1df9 authored by Revant Nandgaonkar's avatar Revant Nandgaonkar

update: root and packages

Merge branch 'update-dependencies' into 'develop'

See merge request castlecraft/building-blocks!294
parents 75e526db e8523068
image: registry.gitlab.com/castlecraft/docker-craft/node-latest-dockerize:latest
image: registry.gitlab.com/castlecraft/docker-craft/node-latest-headless-chrome:latest
services:
- name: bitnami/mongodb:latest
......@@ -111,7 +111,6 @@ test_identity_provider:
- docker
test_identity_client:
image: registry.gitlab.com/castlecraft/docker-craft/node-lts-headless-chrome:latest
stage: tests
before_script:
- cd frontends/identity-client
......@@ -149,7 +148,6 @@ test_infrastructure_console:
- docker
test_admin_client:
image: registry.gitlab.com/castlecraft/docker-craft/node-lts-headless-chrome:latest
stage: tests
before_script:
- cd frontends/admin-client
......
This diff is collapsed.
......@@ -20,29 +20,29 @@
"test:e2e": "export NODE_ENV=test-e2e && jest --config ./tests/jest-e2e.json --detectOpenHandles --forceExit"
},
"dependencies": {
"@nestjs/common": "^6.1.1",
"@nestjs/core": "^6.1.1",
"@nestjs/common": "^6.2.4",
"@nestjs/core": "^6.2.4",
"@nestjs/cqrs": "^6.0.0",
"@nestjs/microservices": "^6.1.1",
"@nestjs/microservices": "^6.2.4",
"@nestjs/mongoose": "^6.1.2",
"@nestjs/platform-express": "^6.1.1",
"@nestjs/platform-express": "^6.2.4",
"@nestjs/swagger": "^3.0.2",
"@nestjs/websockets": "^6.1.1",
"bull": "^3.8.1",
"class-transformer": "^0.2.0",
"@nestjs/websockets": "^6.2.4",
"bull": "^3.9.1",
"class-transformer": "^0.2.3",
"class-validator": "^0.9.1",
"connect-mongo": "^2.0.3",
"cookie-parser": "^1.4.4",
"dotenv": "^8.0.0",
"express": "^4.16.4",
"express-rate-limit": "^3.5.0",
"express": "^4.17.1",
"express-rate-limit": "^4.0.2",
"express-session": "^1.16.1",
"hbs": "^4.0.4",
"helmet": "^3.17.0",
"helmet": "^3.18.0",
"i18n": "^0.8.3",
"joi": "^14.3.1",
"mongodb": "^3.2.3",
"mongoose": "^5.5.5",
"mongodb": "^3.2.6",
"mongoose": "^5.5.11",
"node-jose": "^1.1.3",
"oauth2orize": "^1.11.0",
"oauth2orize-openid": "^0.4.0",
......@@ -55,31 +55,31 @@
"passport-oauth2-code": "^0.1.6",
"qrcode": "^1.3.3",
"reflect-metadata": "^0.1.13",
"rxjs": "^6.5.1",
"rxjs": "^6.5.2",
"speakeasy": "^2.0.0",
"swagger-ui-express": "^4.0.2",
"swagger-ui-express": "^4.0.5",
"uuid": "^3.3.2"
},
"devDependencies": {
"@nestjs/testing": "^6.1.1",
"@types/bull": "^3.5.13",
"@types/connect-mongo": "^0.0.41",
"@nestjs/testing": "^6.2.4",
"@types/bull": "^3.5.14",
"@types/connect-mongo": "0.0.42",
"@types/express": "^4.16.1",
"@types/jest": "^24.0.12",
"@types/jest": "^24.0.13",
"@types/joi": "^14.3.3",
"@types/mongoose": "^5.3.27",
"@types/node": "^12.0.0",
"@types/mongoose": "^5.5.3",
"@types/node": "^12.0.3",
"@types/oauth": "^0.9.1",
"@types/passport-local": "^1.0.33",
"@types/supertest": "^2.0.7",
"jest": "^24.8.0",
"nodemon": "^1.19.0",
"prettier": "^1.17.0",
"nodemon": "^1.19.1",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"supertest": "^4.0.2",
"ts-jest": "^24.0.2",
"ts-loader": "^5.4.5",
"ts-node": "^8.1.0",
"ts-loader": "^6.0.1",
"ts-node": "^8.2.0",
"tsconfig-paths": "^3.8.0",
"tslint": "^5.16.0",
"typescript": "^3.4.5"
......
This diff is collapsed.
......@@ -15,42 +15,42 @@
},
"private": true,
"dependencies": {
"@nestjs/common": "^6.1.1",
"@nestjs/core": "^6.1.1",
"@nestjs/common": "^6.2.4",
"@nestjs/core": "^6.2.4",
"@nestjs/cqrs": "^6.0.0",
"@nestjs/microservices": "^6.1.1",
"@nestjs/platform-express": "^6.1.1",
"@nestjs/microservices": "^6.2.4",
"@nestjs/platform-express": "^6.2.4",
"@nestjs/swagger": "^3.0.2",
"@nestjs/typeorm": "^6.1.0",
"aws-sdk": "^2.449.0",
"class-transformer": "^0.2.0",
"@nestjs/typeorm": "^6.1.1",
"aws-sdk": "^2.464.0",
"class-transformer": "^0.2.3",
"class-validator": "^0.9.1",
"cron": "^1.7.1",
"express": "^4.16.4",
"express": "^4.17.1",
"fastify-formbody": "^3.1.0",
"joi": "^14.3.1",
"mongodb": "^3.2.3",
"nodemailer": "^6.1.1",
"mongodb": "^3.2.6",
"nodemailer": "^6.2.1",
"nodemailer-express-handlebars": "^3.0.0",
"reflect-metadata": "^0.1.13",
"rxjs": "^6.5.1",
"swagger-ui-express": "^4.0.2",
"rxjs": "^6.5.2",
"swagger-ui-express": "^4.0.5",
"typeorm": "^0.2.17"
},
"devDependencies": {
"@nestjs/testing": "^6.1.1",
"@nestjs/testing": "^6.2.4",
"@types/express": "^4.16.1",
"@types/jest": "^24.0.12",
"@types/node": "^12.0.0",
"@types/jest": "^24.0.13",
"@types/node": "^12.0.3",
"@types/supertest": "^2.0.7",
"jest": "^24.8.0",
"nodemon": "^1.19.0",
"prettier": "^1.17.0",
"nodemon": "^1.19.1",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"supertest": "^4.0.2",
"ts-jest": "^24.0.2",
"ts-loader": "^5.4.5",
"ts-node": "^8.1.0",
"ts-loader": "^6.0.1",
"ts-node": "^8.2.0",
"tsconfig-paths": "^3.8.0",
"tslint": "^5.16.0",
"typescript": "^3.4.5"
......
This diff is collapsed.
......@@ -19,39 +19,39 @@
},
"private": true,
"dependencies": {
"@nestjs/common": "^6.1.1",
"@nestjs/core": "^6.1.1",
"@nestjs/common": "^6.2.4",
"@nestjs/core": "^6.2.4",
"@nestjs/cqrs": "^6.0.0",
"@nestjs/platform-express": "^6.1.1",
"@nestjs/platform-express": "^6.2.4",
"@nestjs/swagger": "^3.0.2",
"@nestjs/typeorm": "^6.1.0",
"class-transformer": "^0.2.0",
"@nestjs/typeorm": "^6.1.1",
"class-transformer": "^0.2.3",
"class-validator": "^0.9.1",
"cron": "^1.7.1",
"express": "^4.16.4",
"express": "^4.17.1",
"fastify-formbody": "^3.1.0",
"form-data": "^2.3.3",
"joi": "^14.3.1",
"mongodb": "^3.2.3",
"mongodb": "^3.2.6",
"reflect-metadata": "^0.1.13",
"rxjs": "^6.5.1",
"swagger-ui-express": "^4.0.2",
"rxjs": "^6.5.2",
"swagger-ui-express": "^4.0.5",
"typeorm": "^0.2.17"
},
"devDependencies": {
"@nestjs/testing": "^6.1.1",
"@nestjs/testing": "^6.2.4",
"@types/express": "^4.16.1",
"@types/jest": "^24.0.12",
"@types/node": "^12.0.0",
"@types/jest": "^24.0.13",
"@types/node": "^12.0.3",
"@types/supertest": "^2.0.7",
"jest": "^24.8.0",
"nodemon": "^1.19.0",
"prettier": "^1.17.0",
"nodemon": "^1.19.1",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"supertest": "^4.0.2",
"ts-jest": "^24.0.2",
"ts-loader": "^5.4.5",
"ts-node": "^8.1.0",
"ts-loader": "^6.0.1",
"ts-node": "^8.2.0",
"tsconfig-paths": "^3.8.0",
"tslint": "^5.16.0",
"typescript": "^3.4.5"
......
......@@ -20,39 +20,39 @@
},
"private": true,
"dependencies": {
"@nestjs/common": "^6.1.1",
"@nestjs/core": "^6.1.1",
"@nestjs/common": "^6.2.4",
"@nestjs/core": "^6.2.4",
"@nestjs/cqrs": "^6.0.0",
"@nestjs/platform-express": "^6.1.1",
"@nestjs/platform-express": "^6.2.4",
"@nestjs/swagger": "^3.0.2",
"@nestjs/typeorm": "^6.1.0",
"class-transformer": "^0.2.0",
"@nestjs/typeorm": "^6.1.1",
"class-transformer": "^0.2.3",
"class-validator": "^0.9.1",
"cron": "^1.7.1",
"dotenv": "^8.0.0",
"express": "^4.16.4",
"express": "^4.17.1",
"fastify-formbody": "^3.1.0",
"joi": "^14.3.1",
"mongodb": "^3.2.3",
"mongodb": "^3.2.6",
"reflect-metadata": "^0.1.13",
"rxjs": "^6.5.1",
"swagger-ui-express": "^4.0.2",
"rxjs": "^6.5.2",
"swagger-ui-express": "^4.0.5",
"typeorm": "^0.2.17"
},
"devDependencies": {
"@nestjs/testing": "^6.1.1",
"@nestjs/testing": "^6.2.4",
"@types/express": "^4.16.1",
"@types/jest": "^24.0.12",
"@types/node": "^12.0.0",
"@types/jest": "^24.0.13",
"@types/node": "^12.0.3",
"@types/supertest": "^2.0.7",
"jest": "^24.8.0",
"nodemon": "^1.19.0",
"prettier": "^1.17.0",
"nodemon": "^1.19.1",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"supertest": "^4.0.2",
"ts-jest": "^24.0.2",
"ts-loader": "^5.4.5",
"ts-node": "^8.1.0",
"ts-loader": "^6.0.1",
"ts-node": "^8.2.0",
"tsconfig-paths": "^3.8.0",
"tslint": "^5.16.0",
"typescript": "^3.4.5"
......
......@@ -29,10 +29,8 @@ cd building-blocks
### Bootstrap NodeJS package dependencies
The following command needs nvm and `$HOME/.nvm/nvm.sh` installed.
```
./scripts/bootstrap-dependencies.sh
```sh
rm -fr node_modules && npm i && lerna clean -y && lerna bootstrap
```
### Setup Environment Variables
......
FROM node:lts
FROM node:latest
# Copy and build app
COPY . /home/craft/admin-client
WORKDIR /home/craft
......
This diff is collapsed.
......@@ -3,7 +3,6 @@
"version": "2.0.0",
"scripts": {
"ng": "ng",
"prestart": "./nvm-use.sh",
"start": "ng serve --proxy-config proxy.config.json --host \"admin.localhost\" --port 4220",
"build": "ng build --prod",
"test": "ng test --no-progress",
......@@ -14,31 +13,31 @@
},
"private": true,
"dependencies": {
"@angular/animations": "^7.2.14",
"@angular/cdk": "^7.3.7",
"@angular/common": "^7.2.14",
"@angular/compiler": "^7.2.14",
"@angular/core": "^7.2.14",
"@angular/animations": "^8.0.0",
"@angular/cdk": "^8.0.0",
"@angular/common": "^8.0.0",
"@angular/compiler": "^8.0.0",
"@angular/core": "^8.0.0",
"@angular/flex-layout": "^7.0.0-beta.22",
"@angular/forms": "^7.2.14",
"@angular/http": "^7.2.14",
"@angular/material": "^7.3.7",
"@angular/platform-browser": "^7.2.14",
"@angular/platform-browser-dynamic": "^7.2.14",
"@angular/router": "^7.2.14",
"@angular/forms": "^8.0.0",
"@angular/http": "^7.2.15",
"@angular/material": "^8.0.0",
"@angular/platform-browser": "^8.0.0",
"@angular/platform-browser-dynamic": "^8.0.0",
"@angular/router": "^8.0.0",
"angular-oauth2-oidc": "^5.0.2",
"core-js": "^2.6.5",
"core-js": "^2.6.9",
"hammerjs": "^2.0.8",
"rxjs": "^6.5.1",
"rxjs": "^6.5.2",
"tslib": "^1.9.0",
"zone.js": "^0.9.1"
},
"devDependencies": {
"@angular-devkit/build-angular": "^0.13.8",
"@angular/cli": "^7.3.8",
"@angular/compiler-cli": "^7.2.14",
"@angular/language-service": "^7.2.14",
"@types/jasmine": "^3.3.12",
"@angular-devkit/build-angular": "^0.800.0",
"@angular/cli": "^8.0.0",
"@angular/compiler-cli": "^8.0.0",
"@angular/language-service": "^8.0.0",
"@types/jasmine": "^3.3.13",
"@types/jasminewd2": "~2.0.6",
"codelyzer": "^5.0.1",
"concurrently": "^4.1.0",
......@@ -49,11 +48,11 @@
"karma-coverage-istanbul-reporter": "^2.0.5",
"karma-jasmine": "~2.0.1",
"karma-jasmine-html-reporter": "^1.4.2",
"prettier": "^1.17.0",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"protractor": "~5.4.2",
"ts-node": "^8.1.0",
"ts-node": "^8.2.0",
"tslint": "^5.16.0",
"typescript": "~3.2.2"
"typescript": "^3.4.5"
}
}
......@@ -11,8 +11,8 @@ import { NavigationEnd, Router } from '@angular/router';
styleUrls: ['./listing.component.css'],
})
export class ListingComponent {
@ViewChild(MatPaginator) paginator: MatPaginator;
@ViewChild(MatSort) sort: MatSort;
@ViewChild(MatPaginator, { static: true }) paginator: MatPaginator;
@ViewChild(MatSort, { static: true }) sort: MatSort;
dataSource: ListingDataSource;
displayedColumns = ['name', 'uuid'];
......
FROM node:lts
FROM node:latest
# Copy and build app
COPY . /home/craft/authorization-client
WORKDIR /home/craft
......
......@@ -3,7 +3,6 @@
"version": "2.0.0",
"scripts": {
"ng": "ng",
"prestart": "./nvm-use.sh",
"start": "ng serve --proxy-config proxy.config.json --host \"accounts.localhost\" --port 4210",
"build": "ng build --prod --aot=false --build-optimizer=false",
"test": "ng test --no-progress",
......@@ -14,33 +13,33 @@
},
"private": true,
"dependencies": {
"@angular/animations": "^7.2.14",
"@angular/cdk": "^7.3.7",
"@angular/common": "^7.2.14",
"@angular/compiler": "^7.2.14",
"@angular/core": "^7.2.14",
"@angular/animations": "^8.0.0",
"@angular/cdk": "^8.0.0",
"@angular/common": "^8.0.0",
"@angular/compiler": "^8.0.0",
"@angular/core": "^8.0.0",
"@angular/flex-layout": "^7.0.0-beta.22",
"@angular/forms": "^7.2.14",
"@angular/http": "^7.2.14",
"@angular/material": "^7.3.7",
"@angular/platform-browser": "^7.2.14",
"@angular/platform-browser-dynamic": "^7.2.14",
"@angular/platform-server": "^7.2.14",
"@angular/router": "^7.2.14",
"core-js": "^2.6.5",
"@angular/forms": "^8.0.0",
"@angular/http": "^7.2.15",
"@angular/material": "^8.0.0",
"@angular/platform-browser": "^8.0.0",
"@angular/platform-browser-dynamic": "^8.0.0",
"@angular/platform-server": "^8.0.0",
"@angular/router": "^8.0.0",
"core-js": "^2.6.9",
"hammerjs": "^2.0.8",
"rxjs": "^6.5.1",
"rxjs": "^6.5.2",
"tslib": "^1.9.0",
"zone.js": "^0.9.1"
},
"devDependencies": {
"@angular-devkit/build-angular": "^0.13.8",
"@angular/cli": "^7.3.8",
"@angular/compiler-cli": "^7.2.14",
"@angular/language-service": "^7.2.14",
"@types/jasmine": "^3.3.12",
"@angular-devkit/build-angular": "^0.800.0",
"@angular/cli": "^8.0.0",
"@angular/compiler-cli": "^8.0.0",
"@angular/language-service": "^8.0.0",
"@types/jasmine": "^3.3.13",
"@types/jasminewd2": "~2.0.3",
"@types/node": "^10.14.6",
"@types/node": "^12.0.3",
"codelyzer": "^5.0.1",
"jasmine-core": "^3.4.0",
"jasmine-spec-reporter": "~4.2.1",
......@@ -49,11 +48,11 @@
"karma-coverage-istanbul-reporter": "~2.0.1",
"karma-jasmine": "^2.0.1",
"karma-jasmine-html-reporter": "^1.4.2",
"prettier": "^1.17.0",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"protractor": "~5.4.0",
"ts-node": "^8.1.0",
"ts-node": "^8.2.0",
"tslint": "^5.16.0",
"typescript": "~3.2.2"
"typescript": "^3.4.5"
}
}
......@@ -37,10 +37,10 @@ export class LoginComponent implements OnInit {
disableLoginChoice: boolean = false;
disableResendOTP: boolean = false;
@ViewChild('password') passwordRef: ElementRef;
@ViewChild('otp') otpRef: ElementRef;
@ViewChild('username') usernameRef: ElementRef;
@ViewChild('reSendOTP') reSendOTPRef: ElementRef;
@ViewChild('password', { static: true }) passwordRef: ElementRef;
@ViewChild('otp', { static: true }) otpRef: ElementRef;
@ViewChild('username', { static: true }) usernameRef: ElementRef;
@ViewChild('reSendOTP', { static: true }) reSendOTPRef: ElementRef;
verifyUserForm = new FormGroup({
username: new FormControl(this.username),
......
FROM node:lts
FROM node:latest
# Copy and build app
COPY . /home/craft/identity-client
WORKDIR /home/craft
......
This diff is collapsed.
......@@ -3,7 +3,6 @@
"version": "2.0.0",
"scripts": {
"ng": "ng",
"prestart": "./nvm-use.sh",
"start": "ng serve --proxy-config proxy.config.json --host \"myaccount.localhost\" --port 4420",
"build": "ng build --prod",
"test": "ng test --no-progress",
......@@ -14,33 +13,33 @@
},
"private": true,
"dependencies": {
"@angular/animations": "^7.2.14",
"@angular/cdk": "^7.3.7",
"@angular/common": "^7.2.14",
"@angular/compiler": "^7.2.14",
"@angular/core": "^7.2.14",
"@angular/animations": "^8.0.0",
"@angular/cdk": "^8.0.0",
"@angular/common": "^8.0.0",
"@angular/compiler": "^8.0.0",
"@angular/core": "^8.0.0",
"@angular/flex-layout": "^7.0.0-beta.22",
"@angular/forms": "^7.2.14",
"@angular/http": "^7.2.14",
"@angular/material": "^7.3.7",
"@angular/platform-browser": "^7.2.14",
"@angular/platform-browser-dynamic": "^7.2.14",
"@angular/router": "^7.2.14",
"@angular/forms": "^8.0.0",
"@angular/http": "^7.2.15",
"@angular/material": "^8.0.0",
"@angular/platform-browser": "^8.0.0",
"@angular/platform-browser-dynamic": "^8.0.0",
"@angular/router": "^8.0.0",
"angular-oauth2-oidc": "^5.0.2",
"core-js": "^2.6.5",
"core-js": "^2.6.9",
"hammerjs": "^2.0.8",
"ngx-material-file-input": "^1.1.1",
"rxjs": "^6.5.1",
"rxjs": "^6.5.2",
"zone.js": "^0.9.1"
},
"devDependencies": {
"@angular-devkit/build-angular": "^0.13.8",
"@angular/cli": "^7.3.8",
"@angular/compiler-cli": "^7.2.14",
"@angular/language-service": "^7.2.14",
"@types/jasmine": "^3.3.12",
"@angular-devkit/build-angular": "^0.800.0",
"@angular/cli": "^8.0.0",
"@angular/compiler-cli": "^8.0.0",
"@angular/language-service": "^8.0.0",
"@types/jasmine": "^3.3.13",
"@types/jasminewd2": "~2.0.6",
"@types/node": "^10.14.6",
"@types/node": "^12.0.3",
"codelyzer": "^5.0.1",
"jasmine-core": "^3.4.0",
"jasmine-spec-reporter": "~4.2.1",
......@@ -49,11 +48,11 @@
"karma-coverage-istanbul-reporter": "^2.0.5",
"karma-jasmine": "~2.0.1",
"karma-jasmine-html-reporter": "^1.4.2",
"prettier": "^1.17.0",
"prettier": "^1.17.1",
"prettier-check": "^2.0.0",
"protractor": "~5.4.2",
"ts-node": "^8.1.0",
"ts-node": "^8.2.0",
"tslint": "^5.16.0",
"typescript": "~3.2.2"
"typescript": "^3.4.5"
}
}
This diff is collapsed.
......@@ -4,8 +4,8 @@
"docs": "./scripts/build-docs.sh"
},
"devDependencies": {
"@types/node": "^12.0.0",
"lerna": "^3.13.4",
"@types/node": "^12.0.3",
"lerna": "^3.14.1",
"npm-check": "^5.9.0",
"typedoc": "^0.14.2"
}
......
#!/bin/bash
unset npm_config_prefix
source $HOME/.nvm/nvm.sh
# Script needs to be executed from
# building-blocks lerna / monorepo root
rm -fr node_modules && npm i
lerna clean -y
lerna bootstrap --scope={authorization-server,communication-server,identity-provider,infrastructure-console}
nvm use lts/dubnium
lerna bootstrap --scope={admin-client,authorization-client,identity-client}
lerna clean -y && lerna bootstrap
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment